Home > ipv6 > EDPnet goes IPV6

EDPnet goes IPV6

So, about one year after the first announcement, The Belgian DSL provider EDPnet has started a test-group for native ipv6.

Their ipv6 does not work on the standard (by Belgacom issued) Sagem modems.
You will need to place a router behind the Sagem, which bridges PPPoE perfectly through.

I placed a Mikrotik RB1200 firmware version 5.12.

The IPV6 is enabled through DHCPv6 and you are given an /48 or /56 range, depending if you have static or dynamic ip contract.

I will post here how to have a basic setup to get ipv6 working on your MikroTik.

I assume you already have set up PPPoE. If you don’t know how to initially use the router, please read the documentation first.

The configuration example here is done over the MikroTik terminal.


/ipv6 dhcp-client
add disabled=no interface=pppoe-edpnet-v6 pool-name=DSL pool-prefix-length=48

The interface is the PPPoE interface you created to connect.
The pool-prefix-length is depending on what kind of contract you have, dynamic ip’s = 56, static = 48
Now for the lan-side:

/ipv6 address add from-pool=DSL interface=BR-LAN advertise=yes

The pool was defined in the DHCP-Client
the interface is the LAN interface you have.
advertise will make sure the devices on the lan get router advertisement, so they will obtain a IPV6 IP.
Now the firewall settings

/ipv6 firewall filter
add action=accept chain=input comment="Router - Allow IPv6 ICMP Traffic" disabled=no protocol=icmpv6
add action=accept chain=input comment="Router - Accept established connections" connection-state=established \
 disabled=no
add action=accept chain=input comment="Router - Accept related connections" connection-state=related disabled=\
 no
add action=drop chain=input comment="Router - Drop invalid connections" connection-state=invalid disabled=no
add action=accept chain=input comment="Router- UDP" disabled=no protocol=udp
add action=accept chain=input comment="Router - From our LAN" disabled=no in-interface=BR-LAN
add action=log chain=input comment="Router - Log everything else" disabled=no log-prefix="DROP IP6 INPUT"
add action=drop chain=input comment="Router - Drop everything else" disabled=no
add action=drop chain=forward comment="Lan - Drop invalid Connections" connection-state=invalid disabled=no
add action=accept chain=forward comment="Lan - Accept UDP" disabled=no protocol=udp
add action=accept chain=forward comment="LAN - Accept ICMPv6 " disabled=no protocol=icmpv6
add action=accept chain=forward comment="Lan - Accept established Connections" connection-state=established \
 disabled=no
add action=accept chain=forward comment="Lan - Accept related connections" connection-state=related disabled=\
 no
add action=accept chain=forward comment="Lan - From our Lan" disabled=no in-interface=BR-LAN
add action=log chain=forward comment="Lan - Log everything else" disabled=no log-prefix="Log IPv6"
add action=reject chain=forward comment="Lan - Drop everything else" connection-state=new disabled=no \
 in-interface=pppoe-edpnet-v6 reject-with=icmp-no-route

If more details are needed how to set up mikrotik for DSL, leave a comment, i’ll try to update this post then to help out.

Note this is an example and will not guarantee to work with everybody.

I’m not responsible if you fail miserably.

Categories: ipv6 Tags:
  1. Uloga
    mei 18th, 2019 at 08:59 | #1

    Hey, I’m having issues with this. I’m sorry I know this post is old.

    The fact is that on the first step I do not get any IP adress. It stays on “searching”

  2. juni 7th, 2019 at 13:20 | #2

    Hi,
    Have you tried a different pool prefix length? for me it’s an 48, but your provider could be only giving a 64

  3. december 14th, 2019 at 23:49 | #3

    (Mikrotik RouterOS v6.44+, IPv6 enabled on EDPnet config, BBox3 in factory default bridged mode)

    enabled = yes
    interface = pppoe-client
    Request = [_] info, [_] address, [X] prefix
    pool name = ipv6-pool-local
    pool prefix length = 56
    prefix hint = ::/0
    use peer dns = [_]
    rapid commit = [X]
    add default route = [_]

    these settings hooks immediately a local pool with /56 prefix, as EDPnet.be clearly says.

  4. februari 22nd, 2020 at 17:57 | #4

    MikroTik has changed something, now you need to change your first IP request for a prefix

    Next is the new and correct one:
    /ipv6 dhcp-client
    add disabled=no interface=pppoe-edpnet-v6 pool-name=DSL pool-prefix-length=48 request=prefix

    Thanks

  1. No trackbacks yet.